Error. The Login procedure cannot contact the gateway
Topics about the wireless hardware

Rate this topic
   Post Reply
33 posts
worldvoice
Posts: 22
Joined: 17 Mar 2020, 20:41

Error. The Login procedure cannot contact the gateway

by worldvoice » 18 Mar 2020, 12:40

On our server online (CentOS 6.10), We have HSNM Appliance running on VMware workstation 12.5.9.
HSNM in the VMware is on a NAT with the server (on public IP). The NAT network of the vmware is 192.168.27.0 and the HSNM (in the vmware) has an ip of 192.168.27.2
We can access the HSNM Appliance's web interface by openning through http://public IP/
When we configure a gateway (RouterBoard with Wi-Fi) in HSNM and carry the configurations and put in the router and attemp to connect devices, the welcome portal opens propally. Users can register themselves, and also recharge (through vouchers) their accounts.
But the problem now is that, the HSNM server can not communicate with the gateway ( even on a public IP) to permit the user be connected to the internet through the gateway.

We were advised by the HSNM support team to ensure that all the necessary ports (80, 1514, 1812, 1813, 443) be opened. We have done that. We even took the risk to "turn off" the iptables completely but we still get the same problem mentioned above.

Explicit description of our HSNM configurations.

1) Under the "system settings" under the "Admin tab", everything was left in default except the following;

1.1) In "network" setting, we have;
a) Server Rule --> Master
b) IP Address --> 192.168.27.2 (IP address from the NAT configured for VMware.
c) Subnet Mask --> 24
d) Gateway --> 192.168.27.1 (NAT gateway set up in VMware)


1.2) In "web server", we have;

a) Domain Name --> set the public IP of CentOS 6 server.

1.3) In "Radius" settings we have;

a) Secret --> Our Radius secret
b) Timeout --> 3000 miliseconds

2) Under the "Gateway" settings under the "Admin tab", everything was left in default except the following;

2.1) under "General Data" everything was left in default except the following;

a) Activate Logs --> Enabled
b) Internet Connection IP Address or DynDNS Name --> Static Public IP of our Gateway (RouterBoard)
c) URL or IP to Access the Web Management --> Static Public IP of our Gateway (RouterBoard)
d) Hardware Type --> RBx
e) Maximum Number of Users --> 0 (which means infinity)
f) Welcome Portal Template --> Green Park (default welcome portal)

2.2) under "Fields for Configuring the Gateway" everything was left in default except the following;

2.2.1) Under "Authentication Options"

a) Authentication via Mac Address --> left unticked

2.2.2) Under "Wireless"

a) Use wireless --> ticked
b) SSID --> Our SSID for hotspot

2.2.3) Under "Wan"

a) Same Network of the appliance --> unticked
b) Addressing Mode --> Static IP or DHCP
c) WAN Interface --> Ether1
d) It uses a VLAN --> unticked
f) It uses DHCP Client for the WAN --> unticked
g) WAN IP Address --> Static public IP for our Gateway (RouterBoard)
h) WAN Network Mask --> Network mask of our gateway IP.
i) WAN Gateway --> gateway IP of the WAN interface of our Gateway (RouterBoard)

2.2.4) Under "Hotspot"

a) Add Ether2 to Hotspot Bridge --> ticked (only Ether2 is ticked for the bridge ports)
b) Keep-Alive Timeout --> 72 Hours
c) IP Address --> 10.10.10.1 (IP address of the WLAN1 or Ether2 of Our Gateway)
d) Network Mask --> 255.0.0.0 (Subnet mask of the network 10.10.10.0 above)
f) DNS IP Addresses --> 8.8.8.8 (google's DNS)
g) First IP Address for the DHCP Address Pool --> 10.10.10.253
h) Last IP Address for the DHCP Address Pool --> 10.10.10.2
i) DHCP Lease Time --> 72hours

What are we suppose to fix?

Any help will be appareciated
You do not have the required permissions to view the files attached to this post.

worldvoice
Posts: 22
Joined: 17 Mar 2020, 20:41

Re: Error. The Login procedure cannot contact the gateway

by worldvoice » 18 Mar 2020, 12:43

The screenshot for the NAT configuration of the previous message is seen below.
You do not have the required permissions to view the files attached to this post.

HSNMSupport
Posts: 1304
Joined: 26 Jul 2016, 09:16

Re: Error. The Login procedure cannot contact the gateway

by HSNMSupport » 18 Mar 2020, 16:31

Hi,
in the upcoming version 7.0.140, it will be released a fix for this.
Please wait till the release will be completed, install it the give a try then give us feedback.
Have a nice day.

worldvoice
Posts: 22
Joined: 17 Mar 2020, 20:41

Re: Error. The Login procedure cannot contact the gateway

by worldvoice » 03 Apr 2020, 18:15

Hello!

Following your reply as indicated in the quote below, we have updated our HSNM SYSTEM from version 6 to version 7.0.147.
Hi,
in the upcoming version 7.0.140, it will be released a fix for this.
Please wait till the release will be completed, install it the give a try then give us feedback.
Have a nice day.
We configured a hotspot (RouterBoard) with a public IP address. And maintained the configuration in the quote below, but we still find ourselves with the same error message at the welcome portal as indicated in the screenshot below.
On our server online (CentOS 6.10), We have HSNM Appliance running on VMware workstation 12.5.9.
HSNM in the VMware is on a NAT with the server (on public IP). The NAT network of the vmware is 192.168.27.0 and the HSNM (in the vmware) has an ip of 192.168.27.2
We can access the HSNM Appliance's web interface by openning through http://public IP/
When we configure a gateway (RouterBoard with Wi-Fi) in HSNM and carry the configurations and put in the router and attemp to connect devices, the welcome portal opens propally. Users can register themselves, and also recharge (through vouchers) their accounts.
But the problem now is that, the HSNM server can not communicate with the gateway ( even on a public IP) to permit the user be connected to the internet through the gateway.

We were advised by the HSNM support team to ensure that all the necessary ports (80, 1514, 1812, 1813, 443) be opened. We have done that. We even took the risk to "turn off" the iptables completely but we still get the same problem mentioned above.

Explicit description of our HSNM configurations.

1) Under the "system settings" under the "Admin tab", everything was left in default except the following;

1.1) In "network" setting, we have;
a) Server Rule --> Master
b) IP Address --> 192.168.27.2 (IP address from the NAT configured for VMware.
c) Subnet Mask --> 24
d) Gateway --> 192.168.27.1 (NAT gateway set up in VMware)


1.2) In "web server", we have;

a) Domain Name --> set the public IP of CentOS 6 server.

1.3) In "Radius" settings we have;

a) Secret --> Our Radius secret
b) Timeout --> 3000 miliseconds

2) Under the "Gateway" settings under the "Admin tab", everything was left in default except the following;

2.1) under "General Data" everything was left in default except the following;

a) Activate Logs --> Enabled
b) Internet Connection IP Address or DynDNS Name --> Static Public IP of our Gateway (RouterBoard)
c) URL or IP to Access the Web Management --> Static Public IP of our Gateway (RouterBoard)
d) Hardware Type --> RBx
e) Maximum Number of Users --> 0 (which means infinity)
f) Welcome Portal Template --> Green Park (default welcome portal)

2.2) under "Fields for Configuring the Gateway" everything was left in default except the following;

2.2.1) Under "Authentication Options"

a) Authentication via Mac Address --> left unticked

2.2.2) Under "Wireless"

a) Use wireless --> ticked
b) SSID --> Our SSID for hotspot

2.2.3) Under "Wan"

a) Same Network of the appliance --> unticked
b) Addressing Mode --> Static IP or DHCP
c) WAN Interface --> Ether1
d) It uses a VLAN --> unticked
f) It uses DHCP Client for the WAN --> unticked
g) WAN IP Address --> Static public IP for our Gateway (RouterBoard)
h) WAN Network Mask --> Network mask of our gateway IP.
i) WAN Gateway --> gateway IP of the WAN interface of our Gateway (RouterBoard)

2.2.4) Under "Hotspot"

a) Add Ether2 to Hotspot Bridge --> ticked (only Ether2 is ticked for the bridge ports)
b) Keep-Alive Timeout --> 72 Hours
c) IP Address --> 10.10.10.1 (IP address of the WLAN1 or Ether2 of Our Gateway)
d) Network Mask --> 255.0.0.0 (Subnet mask of the network 10.10.10.0 above)
f) DNS IP Addresses --> 8.8.8.8 (google's DNS)
g) First IP Address for the DHCP Address Pool --> 10.10.10.253
h) Last IP Address for the DHCP Address Pool --> 10.10.10.2
i) DHCP Lease Time --> 72hours

What are we suppose to fix?

Any help will be appareciated

Thank you for any quick response!
You do not have the required permissions to view the files attached to this post.

HSNMSupport
Posts: 1304
Joined: 26 Jul 2016, 09:16

Re: Error. The Login procedure cannot contact the gateway

by HSNMSupport » 06 Apr 2020, 10:10

Hi Paulin
This kind of error mean a communication problem between HSNM and gateway so you have to double check your network configuration. You wrote that vmware where HSNM is installed is natted: what do you mean? Did you set the vmware network interface as NAT instead of as BRIDGE? If YES, please don't do that: the vmware network interface of HSNM must be set to BRIDGE

VmWareNetAdapterSettings.jpg

Belot you can also find a sample network schema that allow you to understand how is the communication between HSNM and GWs

ExampleSchema_3.jpg

Hope this help you

best regards
You do not have the required permissions to view the files attached to this post.

worldvoice
Posts: 22
Joined: 17 Mar 2020, 20:41

Re: Error. The Login procedure cannot contact the gateway

by worldvoice » 06 Apr 2020, 12:27

Hello!
Hi Paulin
This kind of error mean a communication problem between HSNM and gateway so you have to double check your network configuration. You wrote that vmware where HSNM is installed is natted: what do you mean? Did you set the vmware network interface as NAT instead of as BRIDGE? If YES, please don't do that: the vmware network interface of HSNM must be set to BRIDGE

VmWareNetAdapterSettings.jpg

Belot you can also find a sample network schema that allow you to understand how is the communication between HSNM and GWs





Hope this help you

best regards
It is right that our HSNM in VMware is on NAT not BRIDGE. We will change the NAT to BRIDGE and carry out any other modifications to be done with respect to this change, test againg and give you feedbacks.

Thank you for the quick reply!
You do not have the required permissions to view the files attached to this post.

worldvoice
Posts: 22
Joined: 17 Mar 2020, 20:41

Re: Error. The Login procedure cannot contact the gateway

by worldvoice » 09 Apr 2020, 13:27

Hello!

Hello!

It is right that our HSNM in VMware is on NAT not BRIDGE. We will change the NAT to BRIDGE and carry out any other modifications to be done with respect to this change, test againg and give you feedbacks.

Thank you for the quick reply!

Following our previous response,

1) On the HSNM web interface, under Admin --> network settings, we changed the NAT IP, the NAT Gateway, and the NAT Network Mask which we were using to the Public IP of our server, its Network Mask and Gateway.

2) We saved the changes and then restarted the service.

3) Next, we changed the Network Adapter settings of HSNM from NAT to BRIDGE. But we are now unable to access its web interface remotely.

The attached file shows the message we get when we try to load the Appliance's web interface through a web browser (when we enter the server's Public IP) .

Is there something we left out while carrying out these change or that we need to do?

Thank you in advance for helping out!
You do not have the required permissions to view the files attached to this post.

HSNMSupport
Posts: 1304
Joined: 26 Jul 2016, 09:16

Re: Error. The Login procedure cannot contact the gateway

by HSNMSupport » 09 Apr 2020, 16:51

Hi Paulin
I don't know your network topology and your network IP configuration so it quite difficult to help you.
What I can tell you is that you cannot assign to HSNM the same IP address of the server/host where it is running. So if you are running HSNM under vmware player installed on a server/host you cannot give the same IP to the HSNM and to the server.

So, if this is your case, now you must change the IP address of the server/host settings one different from the one set to HSNM but inside the same subnet

Hope this help you

Best regards

worldvoice
Posts: 22
Joined: 17 Mar 2020, 20:41

Re: Error. The Login procedure cannot contact the gateway

by worldvoice » 09 Apr 2020, 17:32

Hello!

Hi Paulin
I don't know your network topology and your network IP configuration so it quite difficult to help you.
What I can tell you is that you cannot assign to HSNM the same IP address of the server/host where it is running. So if you are running HSNM under vmware player installed on a server/host you cannot give the same IP to the HSNM and to the server.

So, if this is your case, now you must change the IP address of the server/host settings one different from the one set to HSNM but inside the same subnet

Hope this help you

Best regards
It is our case, we were giving HSNM the same Public IP address as the server/host.

What are we to do next, please, do we need to only give HSNM a different IP (which will be in the same subnet as the host IP) from that of the server/host?

Thank you for your quick response!
Last edited by worldvoice on 09 Apr 2020, 17:40, edited 1 time in total.

HSNMSupport
Posts: 1304
Joined: 26 Jul 2016, 09:16

Re: Error. The Login procedure cannot contact the gateway

by HSNMSupport » 09 Apr 2020, 17:36

Hi Paulin
I wrote you before what you have to do...I'll write you again: "...now you must change the IP address of the server/host to one different from the one set to HSNM bu,t inside the same subnet..."

Best regards

Rate this topic

Who is online

Users browsing this forum: No registered users and 1 guest