Currently sitting on 10.0.339 coming from 9.3.130.
After the upgrade and re applying the scripts and scheduler (viewtopic.php?f=3&t=4861) the file "radiusip.rsc" contains a config line that disables the Mikrotik ability to answer DNS queries (/ip dns set allow-remote-request=no)
This is not good, we normally use the Mikrotik as the DNS server of the hotspot network and this line breaks things, every X time this configuration is reapplied.
Maybe this has something to do with the "Family DNS" feature, anyway we should have the ability to enable (or disable) this on the gateway config.
For now I have implemented a "fix", an script executed every 10 seconds that checks if the setting has been disabled and in this case it enables it again.
For anyone that might need it here it is:
Code: Select all
/system script
add dont-require-permissions=no name=enableDNS owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
":if ([/ip dns get allow-remote-request] != \"yes\") do={/ip dns set allow-remote-request=yes}"
/system scheduler
add interval=10s name=DNS-Check on-event=enableDNS policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=\
startup
Thanks